Last post Oct 01, 2018 08:46 AM by PatriceSc
Sep 29, 2018 04:28 PM|wavemaster|LINK
I am using the Lighthouse plug in to test my PWA's for performance, best practices, and adherence to the PWA standards.
The best practices section has a vulnerability warning on jquery 1.11.1 for cross-site scripting (XSS) attacks and the suggestion is to upgrade to 3.0.0 or later. XSS explained
Am I putting myself in a world of self inflicted hurt to even attempt to do this? I am not at all proficient in jquery/js, it would take me significant amount of time to research and fix breaking changes.
Oct 01, 2018 08:46 AM|PatriceSc|LINK
Most if not all products have guidance about upgrading and possible breaking changes. See https://jquery.com/upgrade-guide/3.0/