Last post Dec 07, 2007 07:32 PM by happen
Dec 06, 2007 05:36 PM|happen|LINK
Just like discountasp.net , We want to support all frameworks (1,2 and 3) and asp.net versions to date (1,1 2 and 3.5) and installed all frameworks together with the ajax version for asp.net 2. Is it really necessary to have all versions installed, or is the
latest version (3 & 3.5) enough to support all previous things?
Dec 06, 2007 07:20 PM|rmaiya|LINK
As far as I know, .NET 3.0 and 3.5 are backward compatible. So I feel you just need 3.5.
Dec 06, 2007 07:30 PM|OWScott|LINK
v1.1 and v2.0 are actual CLR versions. 3.0 and 3.5 sit on top of v2.0. If you're starting fresh, I would try to nudge everyone to v2.0+ so that you don't need to worry about having people switch framework versions between 2.0 and 1.1. Here's what I recommend
if you can do it:
- install v2.0 which is the base
- install v3.0 and v3.5
The sites will be assigned the v2.0 aspnet_isapi.dll, but they can run all 3.5 code.
If you must support v1.1, then just install that to and make sure that you have a good solution for switching frameworks.
Dec 06, 2007 07:30 PM|happen|LINK
Thanks for your answer. Can anyone confirm this?
Dec 06, 2007 07:37 PM|OWScott|LINK
Further on my previous reply. 98% of v1.1 code will run under the v2.0 framework without any changes, so for the vast majority of the situations, all code will run with the site set for v2.0 (and with the 3.0 and 3.5 extensions installed).
Dec 06, 2007 07:45 PM|happen|LINK
Thanks for your answers Scott. Well, we have Plesk 8.2 for windows on the server, which gives users the ability to switch between asp versions.
Should I uninstall "asp.net 2 ajax extensions" now, as they are standard included in 3.5?
Dec 07, 2007 06:24 PM|OWScott|LINK
They are included in 3.5 but no uninstall is necessary. The 3.5 installer takes care of that.
Dec 07, 2007 07:32 PM|happen|LINK
Thanks, Scott. I've sent you an email.